Archive for October, 2011

EIGRP (a Cisco proprietary routing protocol) is a classless, enhanced distance-vector protocol that uses the concept of Autonomous System to describe the set of contiguous routers that run the same routing protocol and share routing information. EIGRP is a routing protocol that includes the subnet mask in its route updates. EIGRP is suitable for very large networks. It has a maximum hop count of 255.

EIGRP stores data in three tables: Neighbor Table, Topology Table, and Routing Table.

Successor and Feasible Successor
A Successor is the next hop router that provides the least distance to a destination AND is guaranteed not to be a part of some routing loop. A Feasible Successor is the next hop router that is guaranteed not to be a part of some routing loop.

Configuration

1. Configure each of the router’s interfaces.

2. Configure EIGRP as the network’s routing protocol.

R1(config)#router eigrp 10
R1(config-router)#network 192.168.100.0
R1(config-router)#network 192.168.10.0

R2(config)#router eigrp 10
R2(config-router)#network 192.168.100.0
R2(config-router)#network 192.168.200.0
R2(config-router)#network 192.168.20.0

R3(config)#router eigrp 10
R3(config-router)#network 192.168.200.0
R3(config-router)#network 192.168.30.0

3. Optional. Use passive-interface command to prohibit interface/s from sending or receiving Hello Packets. The interface will not send or receive route information.

R3(config)#router eigrp 10
R3(config-router)#passive-interface serial 0/0

4. Use the no-auto summary command to disable summarization. EIGRP will advertise all subnets between two routers. Manual summarization may be used for lager networks.

R1(config)#int f0/0
R1(config-if)# ip summary-address eigrp 10 192.168.10.0 255.255.255.0

R1(config)#router eigrp 10
R1(config-router)#no auto-summary

5. Verify configuration.
Use the following commands to check.
show ip route will show the entire routing table.
show ip route eigrp will show only eigrp entries in the routing table.
show ip eigrp neighbors will show all eigrp neighbors.
show ip eigrp topology will show entries in the eigrp topology table.

R3#show ip route
C    192.168.30.0/24 is directly connected, FastEthernet0/0
D    192.168.10.0/24 [90/2684416] via 192.168.200.1, 00:01:09, Serial0/0
C    192.168.200.0/24 is directly connected, Serial0/0
D    192.168.20.0/24 [90/2172416] via 192.168.200.1, 00:01:09, Serial0/0
D    192.168.100.0/24 [90/2681856] via 192.168.200.1, 00:01:09, Serial0/0

R3#show ip route eigrp
D    192.168.10.0/24 [90/2684416] via 192.168.200.1, 00:01:09, Serial0/0
D    192.168.20.0/24 [90/2172416] via 192.168.200.1, 00:01:09, Serial0/0
D    192.168.100.0/24 [90/2681856] via 192.168.200.1, 00:01:09, Serial0/0

R2#show ip eigrp neighbors
IP-EIGRP neighbors for process 10
H   Address                 Interface       Hold Uptime   SRTT   RTO  Q  Seq
                                            (sec)         (ms)       Cnt Num
1   192.168.200.2           Se0/1             13 00:05:20   32   200  0  2
0   192.168.100.1           Se0/0             13 00:09:04  660  3960  0  4


R1#show ip eigrp topology

IP-EIGRP Topology Table for AS(10)/ID(192.168.100.1)

Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
       r - reply Status, s - sia Status

P 192.168.100.0/24, 1 successors, FD is 2169856
        via Connected, Serial0/0
P 192.168.10.0/24, 1 successors, FD is 28160
        via Connected, FastEthernet0/0
P 192.168.30.0/24, 1 successors, FD is 2684416
        via 192.168.100.2 (2684416/2172416), Serial0/0
P 192.168.20.0/24, 1 successors, FD is 2172416
        via 192.168.100.2 (2172416/28160), Serial0/0
P 192.168.200.0/24, 1 successors, FD is 2681856
        via 192.168.100.2 (2681856/2169856), Serial0/0

RIP, a distance-vector routing protocol, works well in small networks. It sends the complete routing table to all active interfaces every 30 seconds. RIP uses hop count as its routing metric to determine the best path to in a network and has a maximum hop count of 15. It has an Administrative Distance of 20 while Static Routes has an AD of 1.

Three versions of RIP are:
RIPv1 uses classful routing, lacks support for Variable Length Subnet Masks (VLSM).
RIPv2 uses classless routing, supports Classless Inter-Domain Routing (CIDR).
RIPng an extension of RIPv2 for support of IPv6.


Configuration

1. Configure each of the router’s interfaces.

2. Configure RIP as the network’s routing protocol and add all network to be advertised.

R1(config)#router rip
R1(config-router)#network 192.168.10.0
R1(config-router)#network 192.168.10.100


R2(config)#router rip
R2(config-router)#network 192.168.100.0
R2(config-router)#network 192.168.200.0
R2(config-router)#network 192.168.20.0


R3(config)#router rip
R3(config-router)#net 192.168.200.0
R3(config-router)#net 192.168.30.0

3. Use passive-interface command to prevent RIP update broadcsts from being sent out a defined interface. The same interface can still receive RIP updates. (optional)

R1(config)#router rip
R3(config-router)#passive-interface serial 0/0

4. verify connection and routing configuration.

Ping Samples:

R1#ping 192.168.30.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.30.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/64/100 ms


R2#ping 192.168.10.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.10.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/16/36 ms

R2#ping 192.168.30.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.30.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 32/43/64 ms


R3#ping 192.168.10.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.10.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 60/64/68 ms

Routes:


R1#sh ip route
R    192.168.30.0/24 [120/1] via 192.168.100.2, 00:00:23, Serial0/0
C    192.168.10.0/24 is directly connected, FastEthernet0/0
R    192.168.200.0/24 [120/1] via 192.168.100.2, 00:00:23, Serial0/0
R    192.168.20.0/24 [120/1] via 192.168.100.2, 00:00:23, Serial0/0
C    192.168.100.0/24 is directly connected, Serial0/0


R2#sh ip route
R    192.168.30.0/24 [120/1] via 192.168.200.2, 00:00:23, Serial0/1
R    192.168.10.0/24 [120/1] via 192.168.100.1, 00:00:21, Serial0/0
C    192.168.200.0/24 is directly connected, Serial0/1
C    192.168.20.0/24 is directly connected, FastEthernet0/0
C    192.168.100.0/24 is directly connected, Serial0/0


R3#sh ip route
C    192.168.30.0/24 is directly connected, FastEthernet0/0
R    192.168.10.0/24 [120/1] via 192.168.200.1, 00:00:10, Serial0/0
C    192.168.200.0/24 is directly connected, Serial0/0
R    192.168.20.0/24 [120/1] via 192.168.200.1, 00:00:10, Serial0/0
R    192.168.100.0/24 [120/1] via 192.168.200.1, 00:00:10, Serial0/0

A Web Server delivers web pages requested by clients via the internet. Apache has been the most popular and widely used web server today; in fact, it is the default web server on most Linux Distros. Web pages from the Apache Server can be accessed from a web browser, any web browser initiates communication from a web server by making a request using HTTP or HTTPS.

Installing Apache2 on an Ubuntu machine.

sudo apt-get install apache2

After installing apache2, important files are stored in /etc/apache2.
httpd.conf is the main configuration file for Apache.
apache2.conf is the main configuration file for Apache2.

Starting Apache

sudo /etc/init.d/apache2 start
or
sudo service apache2 start
or
sudo service apache2 graceful --> calls apachectl

Stoping Apache2

sudo /etc/init.d/apache2 stop
or
sudo service apache2 stop

apache2ctl
apache2ctl is a management utility, an Apache HTTP server control interface that is also used to start and stop Apache. Commands are:

start -Start the daemon
stop -Stop the daemon
restart -Restart or start the daemon
fullstatus -Report status of server (requires lynx)
graceful -Gracefully restart the server
configtest -Test config file syntax
help -Display commands

For apache2 options, type man apache2 on the terminal. If apache version 1 is installed on a machine, same commands are used, instead apache2 is replaced with httpd.


This is Steve Jobs’ Stanford Commencement speech six years ago. It is really worth watching for! Steve Jobs’ speech was so inspiring, there are lots of lesson to be learned about love, dreams, success, loss, and life.

Here are the best part of his speech that has struck me. You’ll definitely be inspired.

Connecting the dots

You can’t connect the dots looking forward, you can only connect them looking backwards. So you have to trust that the dots will somehow connect in your future. You have to trust in something – your gut, destiny, life, karma, whatever. Because believing that the dots will connect down the road, will give you the confidence to follow your heart, even when it leads you off the well worn path.
And that will make all the difference.

Love and Loss

The heaviness of being successful was replaced by the lightness of being a beginner again, less sure about everything. It freed me to enter one of the most creative periods of my life.

Sometimes life hits you in the head with a brick. Don’t lose faith. I’m convinced that the only thing that kept me going was that I loved what I did. You’ve got to find what you love. And that is as true for your work as it is for your lovers. Your work is going to fill a large part of your life, and the only way to be truly satisfied is to do what you believe is great work. And the only way to do great work is to love what you do. If you haven’t found it yet, keep looking and don’t settle. As with all matters of the heart, you’ll know when you find it. And, like any great relationship, it just gets better and better as the years roll on. So keep looking. Don’t settle.

Death

Your time is limited, so don’t waste it living someone else’s life. Don’t be trapped by dogma — which is living with the results of other people’s thinking. Don’t let the noise of others’ opinions drown out your own inner voice. And most important, have the courage to follow your heart and intuition. They somehow already know what you truly want to become. Everything else is secondary.

Steve Jobs [1955-2011]

“Apple has lost a visionary and creative genius, and the world has lost an amazing human being. Those of us who have been fortunate enough to know and work with Steve have lost a dear friend and an inspiring mentor. Steve leaves behind a company that only he could have built, and his spirit will forever be the foundation of Apple.” 

~www.apple.com

Here are some common keyboard shortcuts I found very useful when surfing the Web with Chrome, Firefox, IE, Opera, and Safari.

These keyboard shortcuts are essential in getting the most out of your chosen browser. These shortcuts can save a lot of time when browsing different sites from the internet.

Feel free to share any additional common browser shortcut you know in the comment section. 🙂