Archive for the ‘Cisco’ Category

EIGRP (a Cisco proprietary routing protocol) is a classless, enhanced distance-vector protocol that uses the concept of Autonomous System to describe the set of contiguous routers that run the same routing protocol and share routing information. EIGRP is a routing protocol that includes the subnet mask in its route updates. EIGRP is suitable for very large networks. It has a maximum hop count of 255.

EIGRP stores data in three tables: Neighbor Table, Topology Table, and Routing Table.

Successor and Feasible Successor
A Successor is the next hop router that provides the least distance to a destination AND is guaranteed not to be a part of some routing loop. A Feasible Successor is the next hop router that is guaranteed not to be a part of some routing loop.

Configuration

1. Configure each of the router’s interfaces.

2. Configure EIGRP as the network’s routing protocol.

R1(config)#router eigrp 10
R1(config-router)#network 192.168.100.0
R1(config-router)#network 192.168.10.0

R2(config)#router eigrp 10
R2(config-router)#network 192.168.100.0
R2(config-router)#network 192.168.200.0
R2(config-router)#network 192.168.20.0

R3(config)#router eigrp 10
R3(config-router)#network 192.168.200.0
R3(config-router)#network 192.168.30.0

3. Optional. Use passive-interface command to prohibit interface/s from sending or receiving Hello Packets. The interface will not send or receive route information.

R3(config)#router eigrp 10
R3(config-router)#passive-interface serial 0/0

4. Use the no-auto summary command to disable summarization. EIGRP will advertise all subnets between two routers. Manual summarization may be used for lager networks.

R1(config)#int f0/0
R1(config-if)# ip summary-address eigrp 10 192.168.10.0 255.255.255.0

R1(config)#router eigrp 10
R1(config-router)#no auto-summary

5. Verify configuration.
Use the following commands to check.
show ip route will show the entire routing table.
show ip route eigrp will show only eigrp entries in the routing table.
show ip eigrp neighbors will show all eigrp neighbors.
show ip eigrp topology will show entries in the eigrp topology table.

R3#show ip route
C    192.168.30.0/24 is directly connected, FastEthernet0/0
D    192.168.10.0/24 [90/2684416] via 192.168.200.1, 00:01:09, Serial0/0
C    192.168.200.0/24 is directly connected, Serial0/0
D    192.168.20.0/24 [90/2172416] via 192.168.200.1, 00:01:09, Serial0/0
D    192.168.100.0/24 [90/2681856] via 192.168.200.1, 00:01:09, Serial0/0

R3#show ip route eigrp
D    192.168.10.0/24 [90/2684416] via 192.168.200.1, 00:01:09, Serial0/0
D    192.168.20.0/24 [90/2172416] via 192.168.200.1, 00:01:09, Serial0/0
D    192.168.100.0/24 [90/2681856] via 192.168.200.1, 00:01:09, Serial0/0

R2#show ip eigrp neighbors
IP-EIGRP neighbors for process 10
H   Address                 Interface       Hold Uptime   SRTT   RTO  Q  Seq
                                            (sec)         (ms)       Cnt Num
1   192.168.200.2           Se0/1             13 00:05:20   32   200  0  2
0   192.168.100.1           Se0/0             13 00:09:04  660  3960  0  4


R1#show ip eigrp topology

IP-EIGRP Topology Table for AS(10)/ID(192.168.100.1)

Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
       r - reply Status, s - sia Status

P 192.168.100.0/24, 1 successors, FD is 2169856
        via Connected, Serial0/0
P 192.168.10.0/24, 1 successors, FD is 28160
        via Connected, FastEthernet0/0
P 192.168.30.0/24, 1 successors, FD is 2684416
        via 192.168.100.2 (2684416/2172416), Serial0/0
P 192.168.20.0/24, 1 successors, FD is 2172416
        via 192.168.100.2 (2172416/28160), Serial0/0
P 192.168.200.0/24, 1 successors, FD is 2681856
        via 192.168.100.2 (2681856/2169856), Serial0/0

RIP, a distance-vector routing protocol, works well in small networks. It sends the complete routing table to all active interfaces every 30 seconds. RIP uses hop count as its routing metric to determine the best path to in a network and has a maximum hop count of 15. It has an Administrative Distance of 20 while Static Routes has an AD of 1.

Three versions of RIP are:
RIPv1 uses classful routing, lacks support for Variable Length Subnet Masks (VLSM).
RIPv2 uses classless routing, supports Classless Inter-Domain Routing (CIDR).
RIPng an extension of RIPv2 for support of IPv6.


Configuration

1. Configure each of the router’s interfaces.

2. Configure RIP as the network’s routing protocol and add all network to be advertised.

R1(config)#router rip
R1(config-router)#network 192.168.10.0
R1(config-router)#network 192.168.10.100


R2(config)#router rip
R2(config-router)#network 192.168.100.0
R2(config-router)#network 192.168.200.0
R2(config-router)#network 192.168.20.0


R3(config)#router rip
R3(config-router)#net 192.168.200.0
R3(config-router)#net 192.168.30.0

3. Use passive-interface command to prevent RIP update broadcsts from being sent out a defined interface. The same interface can still receive RIP updates. (optional)

R1(config)#router rip
R3(config-router)#passive-interface serial 0/0

4. verify connection and routing configuration.

Ping Samples:

R1#ping 192.168.30.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.30.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/64/100 ms


R2#ping 192.168.10.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.10.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/16/36 ms

R2#ping 192.168.30.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.30.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 32/43/64 ms


R3#ping 192.168.10.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.10.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 60/64/68 ms

Routes:


R1#sh ip route
R    192.168.30.0/24 [120/1] via 192.168.100.2, 00:00:23, Serial0/0
C    192.168.10.0/24 is directly connected, FastEthernet0/0
R    192.168.200.0/24 [120/1] via 192.168.100.2, 00:00:23, Serial0/0
R    192.168.20.0/24 [120/1] via 192.168.100.2, 00:00:23, Serial0/0
C    192.168.100.0/24 is directly connected, Serial0/0


R2#sh ip route
R    192.168.30.0/24 [120/1] via 192.168.200.2, 00:00:23, Serial0/1
R    192.168.10.0/24 [120/1] via 192.168.100.1, 00:00:21, Serial0/0
C    192.168.200.0/24 is directly connected, Serial0/1
C    192.168.20.0/24 is directly connected, FastEthernet0/0
C    192.168.100.0/24 is directly connected, Serial0/0


R3#sh ip route
C    192.168.30.0/24 is directly connected, FastEthernet0/0
R    192.168.10.0/24 [120/1] via 192.168.200.1, 00:00:10, Serial0/0
C    192.168.200.0/24 is directly connected, Serial0/0
R    192.168.20.0/24 [120/1] via 192.168.200.1, 00:00:10, Serial0/0
R    192.168.100.0/24 [120/1] via 192.168.200.1, 00:00:10, Serial0/0

Static routing is a data communication concept describing one way of configuring path selection of routers in computer networks [Wikipedia]. Static Routing is achieved by manually adding routes in each router’s routing table. It is commonly used by Network Administrators preferably on small-scale networks.

To create a static route, use the following syntax:
ip route destination_network network_mask next-hop_address_or_exit_interface [administrative_distance] [permanent]

Here’s a quick tutorial on how to manually add routes to a router’s routing table. Let’s say, we want to connect two different networks through static routing: network 10.10.10.0 and network 10.10.20.0.

1. Configure each of the router’s interfaces.

R1(config)#int s0/0
R1(config-if)#ip add 10.10.10.1 255.255.255.0
R1(config-if)#no sh

R2(config)#int s0/0
R2(config-if)#ip add 10.10.10.2 255.255.255.0
R2(config-if)#no sh
R2(config-if)#clock rate 56000
R2(config)#int s0/1
R2(config-if)#ip add 10.10.20.1 255.255.255.0
R2(config-if)#no sh

R3(config)#int s0/0
R3(config-if)#ip add 10.10.20.2 255.255.255.0
R3(config-if)#no sh
R3(config-if)#clock rate 56000

2. Configure static routing on each router.

R1(config)#ip route 10.10.20.0 255.255.255.0 10.10.10.2
R3(config)#ip route 10.10.10.0 255.255.255.0 10.10.20.1

No static routing configuration is needed on R2 since it is connected in both networks.

3. Verify the configuration

R1#ping 10.10.20.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.10.20.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 64/65/68 ms

R3#ping 10.10.10.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.10.10.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 24/56/64 ms

R1#show ip route
     10.0.0.0/24 is subnetted, 2 subnets
C       10.10.10.0 is directly connected, Serial0/0
S       10.10.20.0 [1/0] via 10.10.10.2

R3#show ip route
     10.0.0.0/24 is subnetted, 2 subnets
S       10.10.10.0 [1/0] via 10.10.20.1
C       10.10.20.0 is directly connected, Serial0/0
Router>enable
Router#configure terminal
Router(config)#hostname Router_A
Router_A(config)#enable secret dhee
Router_A(config)#interface f0/0
Router_A(config-if)#ip address 192.168.30.1 255.255.255.0
Router_A(config-if)#description A_Lan Connection
Router_A(config-if)#no shutdown
Router_A(config-if)#interface serial 0/0
Router_A(config-if)#ip address 192.168.20.2 255.255.255.0
Router_A(config-if)#description WAN Connection to Router_A
Router_A(config-if)#clock rate 64000
Router_A(config-if)#no shutdown
Router_A(config-if)#exit
Router_A(config)#line console 0
Router_A(config-line)#password dhee
Router_A(config-line)#login
Router_A(config-line)#line aux 0
Router_A(config-line)#password dhee
Router_A(config-line)#login
Router_A(config-line)#line vty 0 4
Router_A(config-line)#password dhee
Router_A(config-line)#login
Router_A(config-line)#exit
Router_A(config)#banner motd # This is Router A#
Router_A(config)#^z
Router_A#copy running-config startup-config
Destination filename[startup-config]? [Enter]
Router_A#
Ctl+C --> Cancel operation/delete current line

CHANGE

Esc+C --> Capitalize a letter
Esc+L --> Change a word to uppercase/lowercase

DELETE (if curser points out letter m, output will be:)

Character

Ctrl+D --> sample:saple
Ctrl+H --> sample:smple
backspace

Ctrl+U --> (all char from curser to the beginning of the  line) sample:ple
Ctrl+X

CTRL+K --> (all char from curser to the end of the  line) sa

Esc+D -->  (from cursor to end of word) sample:sa

Word

Ctrl+W --> (delete word left of the curser)
Esc+Backspace

MOVE

Character

Ctrl+B --> Left arrow
Ctrl+F --> Right Arrow

Word

Esc+B --> to Left
Esc+F --> to Right

Line

Ctrl+A -->to Start
Ctrl+E -->to End

GNS3 for Beginners

Posted: 08/01/2011 in Cisco
Tags: , ,

GNS3 is an an open source emulation program for anyone who want to pursue a career on Cisco Routing. It’s build on dynagen and dynamips foundation.

I’ve provided you simple steps on how a topology works on GNS3:

  1. Download GNS3 from http://www.gns3.net/download.
  2. Install GNS3.
  3. Run the program and click option 1 on Setup Wizard. “Configure and test the path to Dynamips. Also check that the working directory is valid”. If you exit the Set up wizard, go to Edit | Preferences.
  4. Select a Project Directory. This is the path where your projects are saved.
  5. Select an Image directory. This is the path where IOS images are stored.
  6. Select Dynamips and click Test button. This will return a Dynamips “successfully started” message if Dynamips is running.
  7. Select option 2. Add one or more uncompressed IOS images.
  8. You have to take note of this: The IOS image in BIN format are compressed. You can load IOS image UNPACKED file for faster booting.
  9. Drag and drop devices (with IOS image) to build a topology.
  10. Add router modules (Double click the image, select the device and add slot/s on Slots Tab).
  11. Cable the connections ( Click add a link button on GNS3’s toolbar and select type of cable).
  12. Power the devices by clicking the play button on GNS3’s toolbar.

Some helpful tips:

Use the Idle PC feature to lessen the CPU usage of dynamips when the device is idle. To do this:
Right click the device, select idle PC, select the best idlepc values and select ok.

You can use wireshark captures to check packet data. To do this:
Right Click on the link between two devices, select Capture, then select a source. Go to Edit | Preferences | Capture and modify the settings to make this one work.